Skip to main content
VulnerabilityPublished Updated

CVE-2025-58047: @plone/volto · Volto affected by possible DoS by invoking specific URL by anonymous user

Affects @plone/voltoSource GCVE Database

0
Compare
Authoritative record:CVE-2025-58047· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 16.34.0 soon.

Data as of 4 Nov 2026, 18:17 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 16.34.0, 17.22.1, 18.24.0 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
npm@plone/voltoAffected
  • <16.34.0
Fixed in
  • 16.34.0
npm@plone/voltoAffected
  • >=17.0.0 <17.22.1
Fixed in
  • 17.22.1
npm@plone/voltoAffected
  • >=18.0.0 <18.24.0
Fixed in
  • 18.24.0
npm@plone/voltoAffected
  • >=19.0.0-alpha.1 <19.0.0-alpha.4
Fixed in
  • 19.0.0-alpha.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Volto to one of the patched versions: 16.34.0, 17.22.1, 18.24.0, or 19.0.0-alpha.4 or later. Additionally, configure your environment to automatically restart the Volto server processes if they quit unexpectedly to minimize downtime. This workaround does not prevent the crash but reduces service interruption.

Description

CVE-2025-58047 is a denial-of-service vulnerability in the NodeJS server component of Volto. An anonymous user can trigger a server crash by visiting a specific URL, causing the server process to quit with an error. This issue has been patched in Volto versions 16.34.0, 17.22.1, 18.24.0, and 19.0.0-alpha.4. Users are advised to upgrade to these or later versions. As a mitigation, automatic process restarts can minimize downtime but do not prevent the crash itself.

References

Community reviews

Loading reviews…