Skip to main content
CVE-2026-118785VulnerabilityPublished

Improper Handling of Non-secure-world Input

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-118785· Medium 6.7

Not known to be exploited · CVSS 6.7 Medium : upgrade to 26.09.00 or 26.06.01-lts when convenient.

Data as of 7 Nov 2026, 01:06 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (ENISA)CVSS 3.16.7
Patch
Available – fixed in 26.09.00, 26.06.01-lts
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade MCUXpresso SDK to 26.09.00 or 26.06.01-lts.

Affected software

ProductAffectedFixed in
NXPMCUXpresso SDKAffected
  • <26.09.00
Fixed in
  • 26.09.00
NXPMCUXpresso SDKAffected
  • <26.06.01-lts
Fixed in
  • 26.06.01-lts

AI-suggested

Apply the official fixes by upgrading to versions 26.06.01-lts or later, or 26.09.00 or later, where the vulnerability has been resolved. No other mitigation is indicated or necessary once patched.

Description

A vulnerability in the NSC veneer functions of NXP MCUXpresso SDK TrustZone-M examples allows improper handling of non-secure-world input. This flaw affects versions through 26.06.00-lts and 26.09.00-pvw2 and may enable a non-secure caller to supply unvalidated pointers or untrusted data. The issue can lead to timing side-channel attacks, TOCTOU conditions, or format-string misuse, potentially causing secure-world memory disclosure or denial of service. Versions starting from 26.06.01-lts and 26.09.00 have addressed this vulnerability.

References

Community reviews

Loading reviews…