Skip to main content
CVE-2026-118786VulnerabilityPublished

Improper Input Validation

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-118786· Medium 6.8

Not known to be exploited · CVSS 6.8 Medium : upgrade to 26.12.00-pvw1 or 26.06.01-lts when convenient.

Data as of 7 Nov 2026, 01:06 UTC

CVSS 3.1 base score
6.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (ENISA)CVSS 3.16.8
Patch
Available – fixed in 26.12.00-pvw1, 26.06.01-lts
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade MCUXpresso SDK to 26.12.00-pvw1 or 26.06.01-lts.

Affected software

ProductAffectedFixed in
NXPMCUXpresso SDKAffected
  • <26.12.00-pvw1
Fixed in
  • 26.12.00-pvw1
NXPMCUXpresso SDKAffected
  • <26.06.01-lts
Fixed in
  • 26.06.01-lts

AI-suggested

Upgrade affected NXP MCUXpresso SDK rpmsg-lite multicore example versions to 26.06.01-lts or later, or 26.12.00-pvw1 or later, where this issue is fixed. No other mitigation is indicated by the vendor advisory.

Description

A vulnerability in the NXP MCUXpresso SDK rpmsg-lite multicore example (multicore_examples/rpmsg_lite_pingpong_tzm) up to versions 26.06.00-lts and 26.09.00 allows improper input validation in non-secure-callable veneer functions. This flaw permits a non-secure caller to supply unvalidated pointers and size values, which may lead to disclosure of secure-world memory or denial of service. The issue is fixed in versions starting from 26.06.01-lts and 26.12.00-pvw1.

References

Community reviews

Loading reviews…