CVE-2026-108946: Apache ActiveMQ, Apache ActiveMQ KahaDB · Improper Input Validation Vulnerability
Affects activemq-brokerSource GCVE Database
Not known to be exploited : upgrade to 5.19.12 soon.
Data as of 4 Nov 2026, 16:28 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 5.19.12
Exploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.activemq/activemq-broker to 5.19.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.activemq/activemq-brokerpkg:maven/org.apache.activemq/activemq-brokerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ActiveMQ and Apache ActiveMQ KahaDB to versions 6.4.0, 6.3.3, or 5.19.12 or later, which contain fixes for this vulnerability. No other mitigation actions are indicated by the vendor advisory.
Description
An improper input validation vulnerability in Apache ActiveMQ and Apache ActiveMQ KahaDB allows authenticated clients to spoof other users' connection, session, and consumer IDs. This enables unauthorized consumption from another user's temporary queues or topics, disruption of live subscriptions by tearing them down, and permanent deletion of in-flight, unacknowledged messages via forged acknowledgments. The issue affects versions from 6.0.0 before 6.3.3 and before 5.19.12. Fixed versions are 6.4.0, 6.3.3, and 5.19.12.