Skip to main content
CVE-2026-118095VulnerabilityPublished

David Lingren · Cross-site Scripting

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-118095· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.43 when convenient.

Data as of 29 Oct 2026, 15:56 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Patchstack)CVSS 3.16.5
Patch
Available – fixed in 3.43
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Media LIbrary Assistant to 3.43.

Affected software

ProductAffectedFixed in
Media LIbrary Assistantmedia-library-assistantAffected
  • <3.43
Fixed in
  • 3.43

AI-suggested

If you cannot patch yet, users should apply standard mitigations for DOM-based XSS such as input validation and output encoding where possible.

Description

A DOM-Based Cross-site Scripting (XSS) vulnerability exists in David Lingren's Media Library Assistant up to version 3.42. This vulnerability involves improper neutralization of input during web page generation, which can lead to execution of malicious scripts in the context of the affected web application.

References

Community reviews

Loading reviews…