CVE-2024-3303: Improper Neutralization of Input Used for LLM Prompting in GitLab
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.8.2 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.8.2
Exploitation evidence
Disclosed: evidence found.
CVE published 17 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.8.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches provided by GitLab for versions prior to 17.6.5, 17.7.4, and 17.8.2 to remediate this vulnerability. Upgrading to version 17.8.2 or later will address the issue.
Description
A vulnerability in GitLab Enterprise Edition allows attackers to exfiltrate private issue contents via prompt injection. This affects versions from 16.0 up to but not including 17.8.2. The issue is addressed in patched versions beyond these ranges.