Skip to main content
VulnerabilityPublished Updated

CVE-2026-89161: In PCRE2 before 10.48, pcre2_jit_match mishandles a previously copied subject being passed in as a

Affects pcre2Source GCVE Database

0
Compare
Authoritative record:CVE-2026-89161· High 7.4

Not known to be exploited · CVSS 7.4 High · fixed in 10.48 : patch pcre2 soon.

Data as of 3 Nov 2026, 23:34 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 10.48
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10pcre2pkg:deb/ubuntu/pcre2?arch=source&distro=stonkingOther threatsAffected
  • =10.46-1build1
  • =10.46-1ubuntu1
Fixed in–
Ubuntu 26.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=resoluteOther threatsAffected
  • =10.46-1
  • =10.46-1build1
  • =10.46-1ubuntu0.1
Fixed in–
Ubuntu 24.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=nobleOther threatsAffected
  • 10.42-4 – 10.42-4ubuntu2.2
5 affected builds
Fixed in–
Ubuntu 22.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=jammyOther threatsAffected
  • 10.37-0ubuntu2 – 10.39-3ubuntu0.2
5 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=esm-infra/focalOther threatsAffected
  • 10.32-5 – 10.34-7ubuntu0.1+esm1
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in PCRE2 version 10.48 and later. Users should upgrade to version 10.48 or newer to remediate this vulnerability.

Description

A vulnerability in PCRE2 versions before 10.48 causes the pcre2_jit_match function to mishandle a previously copied subject passed as context, leading to an incorrect free operation. This flaw can result in high impact on confidentiality, integrity, and availability.

References

Community reviews

Loading reviews…