Skip to main content
CVE-2026-89162VulnerabilityPublished Updated

In PCRE2 before 10.48, pcre2_serialize_encode might disclose two bytes to an adversary, typically in a situation where

Affects pcre2Source GCVE Database

0
Compare
Authoritative record:CVE-2026-89162· Low 2.9

Not known to be exploited · CVSS 2.9 Low · fixed in 10.48 : update pcre2 when convenient.

Data as of 3 Nov 2026, 23:35 UTC

CVSS 3.1 base score
2.9Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 10.48
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10pcre2pkg:deb/ubuntu/pcre2?arch=source&distro=stonkingOther threatsAffected
  • =10.46-1build1
  • =10.46-1ubuntu1
Fixed in–
Ubuntu 26.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=resoluteOther threatsAffected
  • =10.46-1
  • =10.46-1build1
  • =10.46-1ubuntu0.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in PCRE2 version 10.48 and later. Users should upgrade to version 10.48 or newer to remediate this vulnerability. No additional mitigation steps are indicated.

Description

A vulnerability in PCRE2 versions before 10.48 allows the pcre2_serialize_encode function to potentially disclose two bytes of memory to an adversary. This issue typically arises in scenarios where the adversary already has unsafe access conditions. The vulnerability has a low severity rating and a CVSS score of 3.3.

References

Community reviews

Loading reviews…