Skip to main content
VulnerabilityPublished Updated

CVE-2026-89160: PCRE2 before 10.48 has a pcre2_match out-of-bounds read during the PCRE2_MATCH_INVALID_UTF matching

Affects pcre2Source GCVE Database

0
Compare
Authoritative record:CVE-2026-89160· Low 3.7

Not known to be exploited · CVSS 3.7 Low.

Data as of 3 Nov 2026, 23:35 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10pcre2pkg:deb/ubuntu/pcre2?arch=source&distro=stonkingOther threatsAffected
  • =10.46-1build1
  • =10.46-1ubuntu1
Fixed in–
Ubuntu 26.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=resoluteOther threatsAffected
  • =10.46-1
  • =10.46-1build1
  • =10.46-1ubuntu0.1
Fixed in–
Ubuntu 24.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=nobleOther threatsAffected
  • 10.42-4 – 10.42-4ubuntu2.2
5 affected builds
Fixed in–
Ubuntu 22.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=jammyOther threatsAffected
  • 10.37-0ubuntu2 – 10.39-3ubuntu0.2
5 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSpcre2pkg:deb/ubuntu/pcre2?arch=source&distro=esm-infra/focalOther threatsAffected
  • 10.32-5 – 10.34-7ubuntu0.1+esm1
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to PCRE2 version 10.48 or later where this vulnerability is fixed. Since the affected versions are explicitly listed, applying the official update from the vendor or distribution maintainers is recommended. No other mitigations or workarounds are documented.

Description

PCRE2 versions before 10.48 contain a vulnerability where the pcre2_match function performs an out-of-bounds read when processing an invalid UTF subject with the PCRE2_MATCH_INVALID_UTF flag. This flaw can lead to information disclosure and potential application instability.

References

Community reviews

Loading reviews…