CVE-2025-29087: In SQLite 3.44.0 through 3.49.0 before 3.49.1, the concat_ws() SQL function can cause memory to be written beyond the end of a malloc-allocated
Affects sqliteSource GCVE Database
Not known to be exploited : upgrade to 3.49.1 soon.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.49.1
Exploitation evidence
Disclosed: evidence found.
CVE published 11 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade sqlite to 3.49.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamisqlitepkg:bitnami/sqliteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in SQLite version 3.49.1 that fixes this vulnerability. Users should upgrade to version 3.49.1 or later to remediate this issue.
Description
SQLite versions 3.44.0 through 3.49.0 before 3.49.1 contain a vulnerability in the concat_ws() SQL function where memory can be written beyond the end of a malloc-allocated buffer. This occurs due to an integer overflow when the separator argument is attacker-controlled and very large, causing insufficient memory allocation.