Skip to main content
CVE-2026-109413VulnerabilityPublished Updated

In Symfony YAML prior to versions 5.4.54, 6.4.45, 7.4.18, and 8.1.6, Yaml\Parser::lexInlineStructure() recursed

Affects symfonySource GCVE Database

0
Authoritative record:CVE-2026-109413· High 8.7

Not known to be exploited · CVSS 8.7 High.

Data as of 29 Oct 2026, 00:13 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10symfonypkg:deb/ubuntu/symfony?arch=source&distro=stonkingOther threatsAffected
  • 7.4.7+dfsg-1ubuntu1 – 7.4.16+dfsg-1ubuntu2
6 affected builds
Fixed in–
Ubuntu 26.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=resoluteOther threatsAffected
  • 6.4.24+dfsg-1 – 7.4.7+dfsg-1ubuntu1
4 affected builds
Fixed in–
Ubuntu Pro 24.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 5.4.23+dfsg-1ubuntu1 – 6.4.5+dfsg-3ubuntu3+esm1
5 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=esm-apps/jammyOther threatsAffected
  • =5.2.6+dfsg-1ubuntu7
  • =5.4.4+dfsg-1ubuntu8
  • =5.4.4+dfsg-1ubuntu8+esm1
Fixed in–
Ubuntu Pro 20.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=esm-apps/focalOther threatsAffected
  • 4.3.4+dfsg-1ubuntu1 – 4.3.8+dfsg-1ubuntu1+esm2
4 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSsymfonypkg:deb/ubuntu/symfony?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 2.8.7+dfsg-1.3ubuntu1 – 3.4.6+dfsg-1ubuntu0.1+esm2
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Symfony YAML to versions 5.4.54, 6.4.45, 7.4.18, or 8.1.6 or later where this issue is fixed. Restrict endpoints that accept YAML input by limiting acceptFormat or applying input validation to prevent deeply nested inline collections. Since a fix is available in the stated versions, applying the official patch is the recommended remediation.

Description

Symfony YAML versions prior to 5.4.54, 6.4.45, 7.4.18, and 8.1.6 contain a vulnerability in Yaml\Parser::lexInlineStructure() where deeply nested inline collections can cause stack exhaustion. This occurs because the parser recurses through inline mappings and sequences without respecting the maxNestingLevel limit, leading to crashes or fatal errors when processing untrusted YAML input. The vulnerability affects any code parsing untrusted YAML, including endpoints using #[MapRequestPayload] without restricting acceptFormat. A single unauthenticated YAML request can trigger this issue.

References

Community reviews

Loading reviews…