Skip to main content
CVE-2026-56817VulnerabilityPublished Updated

netty · In versions 4.2.0.Final through 4.2.15.Final and 4.1.0.Final through 4.1.135.Final, any caller that can deliver bytes

Affects nettySource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.8 Critical · fixed in 4.1.136 : patch netty as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.136
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10nettypkg:deb/ubuntu/netty?arch=source&distro=stonkingOther threatsAffected
  • =1:4.1.48-16
  • =1:4.1.48-16ubuntu1
Fixed in–
Ubuntu Pro 26.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 1:4.1.48-10 – 1:4.1.48-16ubuntu0.1~esm2
7 affected builds
Fixed in–
Ubuntu Pro 24.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 1:4.1.48-7 – 1:4.1.48-9ubuntu0.2+esm2
11 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 1:4.1.48-4 – 1:4.1.48-4+deb11u2ubuntu0.2+esm1
10 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/focalOther threatsAffected
  • 1:4.1.33-1 – 1:4.1.45-1ubuntu0.1~esm7
10 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/bionicOther threatsAffected
  • 1:4.1.7-4 – 1:4.1.7-4ubuntu0.1~esm1
10 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected Netty versions to 4.1.136.Final or later, or 4.2.16.Final or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the available data.

Description

Netty versions 4.2.0.Final through 4.2.15.Final and 4.1.0.Final through 4.1.135.Final contain a vulnerability where an attacker able to send bytes to a channel pipeline with XmlDecoder can exploit XML external entity (XXE) risks via DOCTYPE declarations. This occurs because AsyncXMLInputFactory is instantiated without security configurations, leaving DTD and entity handling active depending on the Aalto XML async parser behavior. The issue is resolved in versions 4.1.136.Final and 4.2.16.Final.

References

Community reviews

Loading reviews…