Skip to main content
CVE-2026-47691VulnerabilityPublished Updated

Prior to versions 4.1.135.Final and 4.2.15.Final, Netty's DnsResolveContext insufficiently validates the bailiwick of

Affects nettySource GCVE Database

0
Compare

Not known to be exploited · CVSS 10.0 Critical : upgrade to 1:4.1.48-9ubuntu0.2+esm2 as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1:4.1.48-9ubuntu0.2+esm2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu netty package to 1:4.1.48-9ubuntu0.2+esm2.

Affected software

ProductAffectedFixed in
Ubuntu 26.10nettypkg:deb/ubuntu/netty?arch=source&distro=stonkingOther threatsAffected
  • =1:4.1.48-16
  • =1:4.1.48-16ubuntu1
Fixed in–
Ubuntu Pro 26.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 1:4.1.48-10 – 1:4.1.48-16ubuntu0.1~esm2
7 affected builds
Fixed in–
Ubuntu 25.10nettypkg:deb/ubuntu/netty?arch=source&distro=questingOther threatsAffected
  • =1:4.1.48-10
  • =1:4.1.48-10ubuntu0.25.10.1
  • =1:4.1.48-10ubuntu0.25.10.2
Fixed in–
Ubuntu Pro 24.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <1:4.1.48-9ubuntu0.2+esm2
Fixed in
  • 1:4.1.48-9ubuntu0.2+esm2
Ubuntu Pro 22.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 1:4.1.48-4 – 1:4.1.48-4+deb11u2ubuntu0.2+esm1
10 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSnettypkg:deb/ubuntu/netty?arch=source&distro=esm-apps/focalOther threatsAffected
  • 1:4.1.33-1 – 1:4.1.45-1ubuntu0.1~esm7
10 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied. Updating Netty to versions 4.1.135.Final or later, or 4.2.15.Final or later, resolves the issue. For Ubuntu users, the fix is provided in package version 1:4.1.48-9ubuntu0.2+esm2 and can be installed via standard system updates or Ubuntu Pro Extended Security Maintenance (ESM). No additional mitigation actions are required beyond applying the official update.

Description

Netty versions prior to 4.1.135.Final and 4.2.15.Final contain a vulnerability in the DnsResolveContext component where NS records' bailiwick validation is insufficient. This flaw allows an attacker controlling an authoritative name server for a subdomain to poison the DNS cache for parent domains by bypassing standard bailiwick rules. The issue is patched in versions 4.1.135.Final and 4.2.15.Final.

References

Community reviews

Loading reviews…