Skip to main content
VulnerabilityPublished Updated

CVE-2025-27446: Incorrect Permission Assignment for Critical Resource vulnerability in Apache

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-27446· High 7.8

Not known to be exploited · CVSS 7.8 High · fixed in 0.6.0 : patch Apache APISIX Java Plugin Runner soon.

Data as of 4 Nov 2026, 17:53 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.6.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.apisix/java-plugin-runnerpkg:maven/org.apache.apisix/java-plugin-runnerOther threatsAffected
  • =0.2.0
  • <=0.5.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache APISIX(java-plugin-runner) to version 0.6.0 or higher, where the incorrect permission assignment vulnerability has been fixed. No additional mitigation actions are indicated.

Description

CVE-2025-27446 is a vulnerability in Apache APISIX's java-plugin-runner component where incorrect permission assignment on local listening files allows a local attacker to elevate privileges. This affects versions from 0.2.0 through 0.5.0. The issue is fixed in version 0.6.0 and later.

References

Community reviews

Loading reviews…