CVE-2025-27446 is a vulnerability in Apache APISIX's java-plugin-runner component where incorrect permission assignment on local listening files allows a local attacker to elevate privileges. This affects versions from 0.2.0 through 0.5.0. The issue is fixed in version 0.6.0 and later.