Skip to main content
VulnerabilityPublished Updated

CVE-2026-33945: Incus instances have an option to provide credentials to systemd in the guest

Affects incusSource GCVE Database

0
Compare
Authoritative record:CVE-2026-33945· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical · fixed in 6.23.0 : patch incus as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.23.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10incuspkg:deb/ubuntu/incus?arch=source&distro=stonkingOther threatsAffected
  • =6.0.5-8
  • =7.0.1-5
Fixed in–
Ubuntu 25.10incuspkg:deb/ubuntu/incus?arch=source&distro=questingOther threatsAffected
  • =6.0.3-4
  • =6.0.4-2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Incus to version 6.23.0 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the root cause of the path traversal in credential configuration keys.

Description

Incus versions prior to 6.23.0 contain a vulnerability where specially crafted configuration keys can cause the system to write files outside the intended credentials directory in the guest container or VM. This allows an attacker with some privileges to write arbitrary files as root, potentially leading to privilege escalation and denial of service. The issue is fixed in version 6.23.0.

References

Community reviews

Loading reviews…