activemq · Input Validation Vulnerability
Affects activemqSource GCVE Database
Not known to be exploited : upgrade to 6.3.3 or 5.19.12 soon.
Data as of 4 Nov 2026, 15:17 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 6.3.3, 5.19.12
Exploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.activemq/activemq to 6.3.3 or 5.19.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.activemq/activemqpkg:maven/org.apache.activemq/activemqOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ActiveMQ to version 6.4.0, 6.3.3, or 5.19.12 to remediate this vulnerability. No other mitigation steps are indicated by the vendor advisory.
Description
An input validation vulnerability exists in Apache ActiveMQ when configured with the LDAPAuthorizationMapPlugin. An authenticated attacker can craft destination names containing LDAP DN special characters to manipulate the LDAP search base used for access control list (ACL) lookups. This flaw affects Apache ActiveMQ versions from 6.3.0 before 6.3.3 and from 5.19.0 before 5.19.12. Upgrading to versions 6.4.0, 6.3.3, or 5.19.12 resolves the issue.