CVE-2024-3250: It was discovered that Canonical's Pebble service manager read-file API and the associated pebble pull command, before v1.10.2, allowed unprivileged
Affects pebbleSource GCVE Database
Not known to be exploited · fixed in 1.10.2 : update pebble when convenient.
Data as of 26 Oct 2026, 14:05 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.10.2, 1.7.3, 1.4.1
Exploitation evidence
Disclosed: evidence found.
CVE published 2 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pebble to 1.10.2, 1.7.3 or 1.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamipebblepkg:bitnami/pebbleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official fixes available in Pebble version 1.10.2 or the backported versions 1.1.1, 1.4.2, and 1.7.4. Upgrading to these versions will remediate the vulnerability. No additional mitigation steps are indicated.
Description
A vulnerability in Canonical's Pebble service manager read-file API and the associated pebble pull command before version 1.10.2 allows unprivileged local users to read files with root-equivalent permissions when Pebble is running as root. Fixes are available in version 1.10.2 and backported to versions 1.1.1, 1.4.2, and 1.7.4. This issue affects multiple version ranges prior to these fixed versions.