CVE-2026-50193: jackson-databind contains the general-purpose data-binding functionality and tree-model for Jackson
Affects jackson-databindSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium · fixed in 2.14.0 : update jackson-databind when convenient.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.14.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10jackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 25.10jackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSjackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSjackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSjackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSjackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=esm-apps/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade jackson-databind to version 2.14.0 or later, where this vulnerability is fixed. No other mitigations are specified or required.
Description
A denial-of-service vulnerability exists in jackson-databind versions from 2.13.0 up to but not including 2.14.0. The issue arises when an attacker sends deeply nested JSON (thousands of levels) that is read as a JsonNode and then written out, causing significant resource consumption. This vulnerability is fixed in version 2.14.0.
References
- ubuntu.com/security/CVE-2026-50193 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-50193 (opens in a new tab)
- github.com/FasterXML/jackson-databind/security/advisories/GHSA-3wrr-7qpf-2prh (opens in a new tab)
- github.com/FasterXML/jackson-databind/issues/3447 (opens in a new tab)
- github.com/FasterXML/jackson-databind/commit/a1fa4ae4ecf5cee16da465985f135f3e81816f8c (opens in a new tab)