CVE-2026-54513: jackson-databind contains the general-purpose data-binding functionality and tree-model for Jackson
Affects jackson-databindSource GCVE Database
Not known to be exploited · CVSS 8.1 High · fixed in 2.18.8 : patch jackson-databind soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 1.2% chance of exploitation in 30 days – higher than 68% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.18.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10jackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSjackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10jackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSjackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSjackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSjackson-databindpkg:deb/ubuntu/jackson-databind?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade jackson-databind to version 2.18.8, 2.21.4, or 3.1.4 or later where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Applying the official fix fully addresses the issue.
Description
A vulnerability in jackson-databind affects versions from 2.10.0 up to but not including 2.18.8, 2.21.4, and 3.1.4. The issue involves the BasicPolymorphicTypeValidator.Builder.allowIfSubTypeIsArray() method, which incorrectly allows any array type based solely on the array nature without validating the component type against the allowlist. This allows instantiation of non-allowlisted component types during deserialization, bypassing intended security checks. The vulnerability is fixed in versions 2.18.8, 2.21.4, and 3.1.4.
References
- ubuntu.com/security/CVE-2026-54513 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-54513 (opens in a new tab)
- github.com/FasterXML/jackson-databind/security/advisories/GHSA-rmj7-2vxq-3g9f (opens in a new tab)
- github.com/FasterXML/jackson-databind/issues/5981 (opens in a new tab)
- github.com/FasterXML/jackson-databind/pull/5983 (opens in a new tab)
- github.com/FasterXML/jackson-databind/pull/5984 (opens in a new tab)
- github.com/FasterXML/jackson-databind/commit/01d1692c8d0ed03e51a0e3c4f8a9e6908e4931e5 (opens in a new tab)
- github.com/FasterXML/jackson-databind/commit/24529da29fdf46ff94ca38de9ebf31cd188f5e8e (opens in a new tab)
- github.com/FasterXML/jackson-databind/issues/5983 (opens in a new tab)