Skip to main content
CVE-2026-122235VulnerabilityPublished

Jan from 0.8.5 before 0.8.8 contains a workspace guard bypass vulnerability in the agent-tools gate.rs that allows

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-122235· Medium 5.7

Not known to be exploited · CVSS 5.7 Medium : upgrade to 0.8.8 when convenient.

Data as of 4 Nov 2026, 22:37 UTC

CVSS 4.0 base score
5.7Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.7
CNA (VulnCheck)CVSS 3.14.7
Patch
Available – fixed in 0.8.8
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade jan to 0.8.8.

Affected software

ProductAffectedFixed in
janhqjanAffected
  • >=0.8.5 <0.8.8
Fixed in
  • 0.8.8
GitHubjanpkg:github/janOther threatsAffected
  • >=0.8.5 <0.8.8
Fixed in
  • 0.8.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid using vulnerable versions and restrict the use of untrusted repositories to mitigate exploitation risk.

Description

Jan versions from 0.8.5 up to but not including 0.8.8 contain a vulnerability in the agent-tools gate.rs component that allows attackers to bypass workspace guards. This flaw enables writing files outside the intended workspace via dangling symlinks, potentially allowing attackers to create or modify sensitive files such as ~/.ssh/authorized_keys on the host system by supplying a malicious repository and using prompt injection.

References

Community reviews

Loading reviews…