JeecgBoot versions through 3.9.2 have a broken access control vulnerability allowing authenticated low-privilege users to fully manage OpenAPI credentials via endpoints lacking proper authorization
Affects jeecgbootSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 3.9.3 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade org.jeecg/jeecgboot to 3.9.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.jeecg/jeecgbootpkg:maven/org.jeecg/jeecgbootOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict access to the affected endpoints and review user privileges to minimize exposure.
Description
JeecgBoot versions through 3.9.2 have a broken access control vulnerability allowing authenticated low-privilege users to fully manage OpenAPI credentials via endpoints lacking proper authorization. This enables attackers to list, add, edit, and delete all API key pairs, with secret keys exposed in plaintext, risking credential theft and unauthorized API access.