Skip to main content
VulnerabilityPublished

Kanidm: Stored HTML injection

Affects kanidmSource GCVE Database

0

CVSS 6.1 Medium : upgrade to 1.9.3 when convenient.

Data as of 27 Oct 2026, 02:27 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.9.3
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N

What to do

Upgrade kanidm to 1.9.3.

Affected software

ProductAffectedFixed in
crates.iokanidmAffected
  • <1.9.3
Fixed in
  • 1.9.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in kanidm version 1.9.3 that fixes this vulnerability. Users should upgrade to version 1.9.3 or later to remediate the issue. No additional mitigation steps are required once the patch is applied.

Description

Kanidm versions prior to 1.9.3 contain a stored HTML injection vulnerability in the WebAuthn passkey-registration challenge rendering. The vulnerability arises because the account's displayname is embedded as raw JSON inside an inline script tag without escaping HTML special characters, allowing an attacker to inject arbitrary HTML. This injection can lead to authenticated same-origin request forgery via htmx attributes, enabling privilege escalation for authenticated users with certain admin rights. The vulnerability is fixed in version 1.9.3.

References

Community reviews

Loading reviews…