CVE-2025-64076: Keeper commander · cbor2 C extension decoder flaws can cause denial of service
Affects keeper-commanderSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 17.1.13 soon.
Data as of 5 Nov 2026, 19:50 UTC
- Patch
- Available – fixed in 17.1.13
CVSS:3.1/AC:L/AV:N/A:H/C:N/I:N/PR:N/S:U/UI:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade keeper-commander to 17.1.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewkeeper-commanderpkg:brew/keeper-commanderOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in cbor2 version 5.7.1. Users and administrators should upgrade to version 5.7.1 or later to remediate these vulnerabilities. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2025-64076 is a high-severity vulnerability in the cbor2 library's C extension decoder affecting versions prior to 5.7.1. It involves an integer underflow causing out-of-bounds reads and a memory leak due to missing reference count releases. These flaws can be exploited remotely by sending crafted CBOR data with multi-byte UTF-8 characters at specific chunk boundaries, leading to denial of service via process crashes or memory exhaustion. The issue affects applications using cbor2's C extension to process untrusted CBOR data, such as web APIs and IoT data collectors. The vulnerability is fixed in version 5.7.1.
References
- nvd.nist.gov/vuln/detail/CVE-2025-64076 (opens in a new tab)
- github.com/agronholm/cbor2/issues/264 (opens in a new tab)
- github.com/agronholm/cbor2/pull/265 (opens in a new tab)
- github.com/agronholm/cbor2/commit/851473490281f82d82560b2368284ef33cf6e8f9 (opens in a new tab)
- github.com/agronholm/cbor2 (opens in a new tab)
- github.com/agronholm/cbor2/releases/tag/5.7.1 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/cbor2/PYSEC-2025-238.yaml (opens in a new tab)