CVE-2026-26209: Keeper commander · cbor2 has a Denial of Service via Uncontrolled Recursion in cbor2.loads
Affects keeper-commanderSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 17.2.10_1 or 17.1.13 soon.
Data as of 5 Nov 2026, 19:50 UTC
- Patch
- Available – fixed in 17.2.10_1, 17.1.13
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade keeper-commander to 17.2.10_1 or 17.1.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewkeeper-commanderpkg:brew/keeper-commanderOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading keeper-commander to versions 17.1.13 or 17.2.10_1 or later. This update includes fixes to limit recursion depth and properly handle recursion errors to prevent process termination. No additional mitigation is required if the patch is applied.
Description
The cbor2 library used by keeper-commander is vulnerable to a Denial of Service (DoS) attack due to uncontrolled recursion when decoding deeply nested CBOR data structures. An attacker can craft a CBOR payload with thousands of nested arrays that causes the decoder to exceed Python's recursion limit, triggering a RecursionError. In some environments, this exception is not properly handled, causing the process to terminate. This vulnerability affects both the pure Python and C extension implementations of cbor2. It impacts applications parsing untrusted CBOR data, such as IoT systems and WebAuthn flows. The issue is patched in keeper-commander versions 17.1.13 and 17.2.10_1.
References
- github.com/agronholm/cbor2/security/advisories/GHSA-3c37-wwvx-h642 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-26209 (opens in a new tab)
- github.com/agronholm/cbor2/pull/275 (opens in a new tab)
- github.com/agronholm/cbor2/commit/e61a5f365ba610d5907a0ae1bc72769bba34294b (opens in a new tab)
- github.com/agronholm/cbor2 (opens in a new tab)
- github.com/agronholm/cbor2/releases/tag/5.9.0 (opens in a new tab)