Skip to main content
VulnerabilityPublished Updated

CVE-2025-66034: Keeper commander · fontTools is Vulnerable to Arbitrary File Write and XML injection in fontTools.varLib

Affects keeper-commanderSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.3 Medium : upgrade to 17.1.15_1 when convenient.

Data as of 5 Nov 2026, 19:51 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 17.1.15_1
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade keeper-commander to 17.1.15_1.

Affected software

ProductAffectedFixed in
Homebrewkeeper-commanderpkg:brew/keeper-commanderOther threatsAffected
  • >=17.0.21 <17.1.15_1
Fixed in
  • 17.1.15_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading keeper-commander to version 17.1.15_1 or later. This update fixes the arbitrary file write and XML injection vulnerabilities. No additional mitigation steps are required beyond applying the official fix.

Description

The fontTools varLib component in keeper-commander versions >=17.0.21 and <17.1.15_1 contains an arbitrary file write vulnerability via unsanitized filename handling and XML injection in .designspace files. This flaw allows attackers to write files to arbitrary filesystem locations, including overwriting configuration and application files, and inject malicious code that can lead to remote code execution without elevated privileges. The vulnerability is fixed in version 17.1.15_1.

References

Community reviews

Loading reviews…