Kimi cli: GitPython Remote.pull() refspec bypasses the --upload-pack unsafe-option guard, enabling arbitrary command
Affects kimi-cliSource GCVE Database
Not known to be exploited · CVSS 9.2 Critical : upgrade to 1.50.0 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.50.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade kimi-cli to 1.50.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewkimi-clipkg:brew/kimi-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in kimi-cli version 1.50.0 that fixes this vulnerability by properly validating the positional refspec argument against unsafe options. Users and administrators should upgrade to version 1.50.0 or later to remediate this issue. Until patched, avoid passing untrusted or attacker-controlled input as the refspec argument to Remote.pull(), especially when using local-path or SSH transports. No other mitigations are documented or required once patched.
Description
A command injection vulnerability exists in the kimi-cli GitPython Remote.pull() method where the positional refspec argument bypasses the unsafe-option guard, allowing an attacker to execute arbitrary commands. This occurs because the unsafe-option check only inspects keyword arguments, not the positional refspec, enabling injection of a malicious --upload-pack option. Exploitation requires the remote to use a local-path or SSH transport, which executes the attacker-supplied command with the privileges of the calling process. The vulnerability affects kimi-cli versions from 1.11.0 up to but not including 1.50.0 and has been assigned CVE-2026-110858 with a high severity CVSS score of 8.1. A fix is available in version 1.50.0.
References
- github.com/gitpython-developers/GitPython/security/advisories/GHSA-f9j4-qggq-h239 (opens in a new tab)
- github.com/gitpython-developers/GitPython/pull/2247 (opens in a new tab)
- github.com/gitpython-developers/GitPython/commit/790bb3164948625ffb043d2a162425d55923fe9a (opens in a new tab)
- github.com/gitpython-developers/GitPython (opens in a new tab)
- github.com/gitpython-developers/GitPython/releases/tag/3.2.0 (opens in a new tab)