Skip to main content
CVE-2026-10087VulnerabilityPublished

GitLab Enterprise Edition · Kwetsbaarheden Verholpen

Affects Nationaal Cyber Security Centrum GitLabSource GCVE Database

0
Compare

Not known to be exploited : upgrade to 19.0.2 soon.

Data as of 30 Oct 2026, 11:52 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 19.0.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Nationaal Cyber Security Centrum GitLab to 19.0.2.

Affected software

ProductAffectedFixed in
Nationaal Cyber Security Centrum GitLabAffected
  • >=12.0 <19.0.2
Fixed in
  • 19.0.2

AI-suggested

A fix is available for these vulnerabilities in GitLab versions 19.0.2 and later. Users should upgrade affected GitLab Community Edition and Enterprise Edition installations to version 19.0.2 or later to remediate these security issues. Since this is a self-hosted product, administrators must apply the updates manually. No additional vendor advisory details were provided, so users should consult official GitLab release notes for precise upgrade instructions.

Description

Multiple vulnerabilities have been fixed in GitLab Community Edition and Enterprise Edition versions ranging from 12.0 up to but not including 19.0.2, including important releases such as 17.x, 18.10.8, 18.11.5, and 19.0.2. These vulnerabilities cover a range of weaknesses identified by various CWE identifiers. No CVSS score is provided, and there are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…