Skip to main content
CVE-2026-122319VulnerabilityPublished

Kyverno before 1.19.2 contains a denial-of-service vulnerability in the In and NotIn operators that allows attackers

Affects kyvernoSource GCVE Database

0
Compare
Authoritative record:CVE-2026-122319· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 1.19.2 soon.

Data as of 5 Nov 2026, 04:26 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 1.19.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade kyverno/kyverno to 1.19.2.

Affected software

ProductAffectedFixed in
GitHubkyverno/kyvernopkg:github/kyverno/kyvernoOther threatsAffected
  • <1.19.2
Fixed in
  • 1.19.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Kyverno version 1.19.2. Users should upgrade to version 1.19.2 or later to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

Kyverno versions prior to 1.19.2 have a denial-of-service vulnerability in the In and NotIn operators. This flaw allows attackers to crash the policy engine by submitting resources that cause a panic due to unchecked type assertions when JMESPath expressions evaluate to arrays containing integers, booleans, or mixed types. The crash disrupts admission control and policy enforcement.

References

Community reviews

Loading reviews…