CVE-2026-17591: libarchive security update
Affects libarchiveSource GCVE Database
Not known to be exploited · CVSS 3.6 Low : upgrade to 3.7.1-14.oe2403sp1 when convenient.
Data as of 29 Oct 2026, 11:17 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.7.1-14.oe2403sp1
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 16 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade libarchive to 3.7.1-14.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1libarchivepkg:rpm/openEuler/libarchive&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in libarchive version 3.7.1-14.oe2403sp1 that fixes this use-after-free vulnerability. Users and administrators should upgrade to this fixed version to remediate the issue. No other mitigations are specified or required.
Description
CVE-2026-17591 is a use-after-free vulnerability in libarchive affecting versions prior to 3.7.1-14.oe2403sp1. The flaw occurs in the archive_entry_copy_mac_metadata() function, where an internal buffer is deallocated before the data copy completes. This can lead to a Denial of Service (application crash) or potential information disclosure by reading uninitialized memory. The vulnerability has a low CVSS score of 3.6 and requires local attacker interaction with high attack complexity. A patch is available in version 3.7.1-14.oe2403sp1.