Skip to main content
VulnerabilityPublished Updated

CVE-2026-78133: strongSwan · Libcharon

Affects strongswanSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 6.0.4-1ubuntu3.2 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.4-1ubuntu3.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Ubuntu strongswan package to 6.0.4-1ubuntu3.2.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=resoluteOther threatsAffected
  • <6.0.4-1ubuntu3.2
Fixed in
  • 6.0.4-1ubuntu3.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and should be applied by updating strongSwan to the patched versions provided by Ubuntu, specifically version 6.0.4-1ubuntu3.2 or later for Ubuntu 26.04 LTS. Standard system updates will apply the necessary patches. No additional mitigation actions are required beyond applying the official update.

Description

A use-after-free vulnerability exists in libcharon of strongSwan versions 6.0.0 through 6.0.7 related to IKEv2 rekeying collision handling. This flaw could allow a remote attacker to execute arbitrary code. The vulnerability affects Ubuntu 26.04 LTS packages of strongSwan. A patch is available to address this issue.

References

Community reviews

Loading reviews…