CVE-2026-110680: Libcpanel json xs perl · Cpanel::JSON::XS versions from 4.20 before 4.80 for Perl write out of bounds
Affects libcpanel-json-xs-perlSource GCVE Database
Not known to be exploited · fixed in 4.80 : update libcpanel-json-xs-perl when convenient.
Data as of 29 Oct 2026, 00:00 UTC
Rated by Threat Radar · CVSS not yet scored by NVD
- Patch
- Available – fixed in 4.80
Exploitation evidence
Disclosed: evidence found.
CVE published 19 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10libcpanel-json-xs-perlpkg:deb/ubuntu/libcpanel-json-xs-perl?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSlibcpanel-json-xs-perlpkg:deb/ubuntu/libcpanel-json-xs-perl?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlibcpanel-json-xs-perlpkg:deb/ubuntu/libcpanel-json-xs-perl?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSlibcpanel-json-xs-perlpkg:deb/ubuntu/libcpanel-json-xs-perl?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSlibcpanel-json-xs-perlpkg:deb/ubuntu/libcpanel-json-xs-perl?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSlibcpanel-json-xs-perlpkg:deb/ubuntu/libcpanel-json-xs-perl?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of Cpanel::JSON::XS is available starting from version 4.80. Users should upgrade to version 4.80 or later to remediate this vulnerability. No other mitigation or temporary workaround is indicated in the provided data.
Description
Cpanel::JSON::XS versions from 4.20 before 4.80 for Perl have a write out of bounds vulnerability during canonical encoding of tied or shared hashes. This occurs when the hash grows between two passes of key counting and sorting, causing memory corruption and potential process crashes.