Skip to main content
VulnerabilityPublished

CVE-2026-111269: libical security update

Affects libicalSource GCVE Database

0
Compare
Authoritative record:CVE-2026-111269· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 3.0.11-4.oe2203sp4 when convenient.

Data as of 29 Oct 2026, 11:05 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.16.1
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.11-4.oe2203sp4
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 15 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 2 hours before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 11 days after disclosure

  4. In Threat Radar

    record ingested

    , 11 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade libical to 3.0.11-4.oe2203sp4.

Affected software

ProductAffectedFixed in
openEuler 22.03-LTS-SP4libicalpkg:rpm/openEuler/libical&distro=openEuler-22.03-LTS-SP4Other threatsAffected
  • <3.0.11-4.oe2203sp4
Fixed in
  • 3.0.11-4.oe2203sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in libical version 3.0.11-4.oe2203sp4 that fixes this vulnerability. Users should upgrade to this fixed version or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

A heap-based out-of-bounds read vulnerability exists in libical versions prior to 3.0.11-4.oe2203sp4 in the function icalvalue_decode_ical_string(). This occurs when decoding iCalendar input that ends with a backslash, potentially causing application crashes or memory leakage.

References

Community reviews

Loading reviews…