CVE-2026-108985: libnfs security update
Affects libnfsSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 5.0.2-4.oe2403sp1 soon.
Data as of 4 Nov 2026, 16:46 UTC
- Patch
- Available – fixed in 5.0.2-4.oe2403sp1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade libnfs to 5.0.2-4.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1libnfspkg:rpm/openEuler/libnfs&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading libnfs to version 5.0.2-4.oe2403sp1 or later. No additional mitigation steps are indicated by the vendor advisory.
Description
A high-severity vulnerability (CVE-2026-108985) exists in libnfs versions prior to 5.0.2-4.oe2403sp1. The flaw is an out-of-bounds write in the ZDR decoding functionality related to lib/libnfs-zdr.c, where the maxsize parameter supplied by the caller is not properly enforced. This can lead to integrity loss and denial of service. A patch fixing this issue is available in version 5.0.2-4.oe2403sp1.