CVE-2026-50256: xorg-x11-server-xwayland security update
Affects xorg-x11-server-xwaylandSource GCVE Database
Not known to be exploited · CVSS 7.8 High : upgrade to xorg-x11-server-Xwayland-22.1.2-38.oe2403sp1 soon.
Data as of 4 Nov 2026, 16:47 UTC
- Patch
- Available – fixed in xorg-x11-server-Xwayland-22.1.2-38.oe2403sp1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade xorg-x11-server-xwayland to xorg-x11-server-Xwayland-22.1.2-38.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1xorg-x11-server-xwaylandpkg:rpm/openEuler/xorg-x11-server-xwayland&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available that fixes these vulnerabilities in xorg-server-21.1.23 and xwayland-24.1.12. Users should apply the official patches or upgrade to these fixed versions (e.g., xorg-x11-server-Xwayland-22.1.2-38.oe2403sp1) to mitigate the risks. No additional mitigations or workarounds are indicated in the advisory.
Description
Multiple security vulnerabilities have been identified in X.Org X server and Xwayland prior to versions 21.1.23 and 24.1.12 respectively. These include stack-based buffer overflows in font alias resolution and XKB key type handling, as well as several use-after-free vulnerabilities in XSYNC components. The vulnerabilities could allow local attackers with limited privileges to cause memory corruption leading to potential code execution or denial of service. Fixes have been released in xorg-server-21.1.23 and xwayland-24.1.12.