CVE-2026-114550: libwebsockets security update
Affects libwebsocketsSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 4.3.0-13.oe2203sp4 soon.
Data as of 4 Nov 2026, 16:58 UTC
Thin evidence
One scorer or none| CNA (zdi) | CVSS 3.0 | 8.1 |
|---|
- Patch
- Available – fixed in 4.3.0-13.oe2203sp4
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade libwebsockets to 4.3.0-13.oe2203sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 22.03-LTS-SP4libwebsocketspkg:rpm/openEuler/libwebsockets&distro=openEuler-22.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade libwebsockets to version 4.3.0-13.oe2203sp4 or later, where this vulnerability has been fixed. No other specific mitigations or countermeasures are documented. Replacing the affected library with an alternative product may be considered if patching is not feasible.
Description
A critical buffer overflow vulnerability (CWE-787) has been identified in libwebsockets, a lightweight C library for network protocols. This flaw allows writing data outside the intended buffer boundaries, impacting confidentiality, integrity, and availability. The vulnerability affects versions prior to 4.3.0-13.oe2203sp4. A fix is available in version 4.3.0-13.oe2203sp4. The CVSS v3.1 base score is 8.1, indicating high severity.