Skip to main content
VulnerabilityPublished

CVE-2026-114550: libwebsockets security update

Affects libwebsocketsSource GCVE Database

0
Compare
Authoritative record:CVE-2026-114550· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 4.3.3-10.oe2403sp3 soon.

Data as of 4 Nov 2026, 16:58 UTC

CVSS 3.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (zdi)CVSS 3.08.1
Patch
Available – fixed in 4.3.3-10.oe2403sp3
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade libwebsockets to 4.3.3-10.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3libwebsocketspkg:rpm/openEuler/libwebsockets&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <4.3.3-10.oe2403sp3
Fixed in
  • 4.3.3-10.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in libwebsockets version 4.3.3-10.oe2403sp3. Users and administrators should upgrade to this fixed version to remediate the vulnerability. No alternative mitigations or countermeasures are currently known.

Description

A critical buffer overflow vulnerability (CWE-787) has been identified in libwebsockets, a lightweight C library for network protocols. This flaw allows writing data beyond the intended buffer boundaries, impacting confidentiality, integrity, and availability. The vulnerability affects versions prior to 4.3.3-10.oe2403sp3. A patch is available in version 4.3.3-10.oe2403sp3. The CVSS 3.1 score is 8.1, indicating high severity.

References

Community reviews

Loading reviews…