CVE-2026-114550: libwebsockets security update
Affects libwebsocketsSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 4.3.3-10.oe2403sp1 soon.
Data as of 4 Nov 2026, 16:58 UTC
Thin evidence
One scorer or none| CNA (zdi) | CVSS 3.0 | 8.1 |
|---|
- Patch
- Available – fixed in 4.3.3-10.oe2403sp1
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade libwebsockets to 4.3.3-10.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1libwebsocketspkg:rpm/openEuler/libwebsockets&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade libwebsockets to version 4.3.3-10.oe2403sp1 or later, where this vulnerability is fixed. No alternative mitigations or countermeasures are currently known. Replacing the affected library with an alternative product may be considered if upgrading is not feasible.
Description
A critical buffer overflow vulnerability (CWE-787) exists in libwebsockets prior to version 4.3.3-10.oe2403sp1. This flaw allows writing data beyond the intended buffer boundaries, impacting confidentiality, integrity, and availability. A fix is available in version 4.3.3-10.oe2403sp1.