Skip to main content
VulnerabilityPublished Updated

CVE-2024-57996: linux-aws-fips, linux-fips, linux-gcp-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 5.4.0-1150.160+fips1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:36 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 5.4.0-1150.160+fips1, 5.4.0-1124.134, 5.4.0-1153.162+fips1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 5.4.0-1150.160+fips1 (linux-aws-fips package) or 5.4.0-1124.134 (linux-fips package) or 5.4.0-1153.162+fips1 (linux-gcp-fips package).

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 20.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/focalOther threatsAffected
  • <5.4.0-1150.160+fips1
Fixed in
  • 5.4.0-1150.160+fips1
Ubuntu Pro FIPS-updates 20.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/focalOther threatsAffected
  • <5.4.0-1124.134
Fixed in
  • 5.4.0-1124.134
Ubuntu Pro FIPS-updates 20.04 LTSlinux-gcp-fipspkg:deb/ubuntu/linux-gcp-fips?arch=source&distro=fips-updates/focalOther threatsAffected
  • <5.4.0-1153.162+fips1
Fixed in
  • 5.4.0-1153.162+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Users must update their systems to the fixed package versions (5.4.0-1124.134, 5.4.0-1150.160+fips1, 5.4.0-1153.162+fips1) via standard system updates. After updating, a system reboot is required to apply the changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. If standard kernel metapackages are installed, the upgrade process will handle this automatically. Follow the Ubuntu advisory USN-7754-2 for detailed instructions.

Description

Multiple security vulnerabilities were identified in the Linux kernel's network traffic control subsystem affecting FIPS-certified kernel packages for AWS, GCP, and generic Linux. These flaws could potentially allow an attacker to compromise the system. The issues are addressed by updates that require a system reboot and recompilation of third-party kernel modules due to ABI changes. Fixed versions have been released and are available through Ubuntu Pro updates.

References

Community reviews

Loading reviews…