Skip to main content
VulnerabilityPublished Updated

CVE-2024-36347: linux-aws-fips, linux-fips, linux-gcp-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2024-36347· Medium 6.4

Not known to be exploited · CVSS 6.4 Medium · fixed in 6.8.0-1052.55+fips1 : update Linux kernel when convenient.

Data as of 31 Oct 2026, 01:10 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.8.0-1052.55+fips1, 6.8.0-110.110+fips2, 6.8.0-1054.57+fips1
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1052.55+fips1 (linux-aws-fips package) or 6.8.0-110.110+fips2 (linux-fips package) or 6.8.0-1054.57+fips1 (linux-gcp-fips package).

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 24.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-1052.55+fips1
Fixed in
  • 6.8.0-1052.55+fips1
Ubuntu Pro FIPS-updates 24.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-110.110+fips2
Fixed in
  • 6.8.0-110.110+fips2
Ubuntu Pro FIPS-updates 24.04 LTSlinux-gcp-fipspkg:deb/ubuntu/linux-gcp-fips?arch=source&distro=fips-updates/nobleOther threatsAffected
  • <6.8.0-1054.57+fips1
Fixed in
  • 6.8.0-1054.57+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in updated Linux kernel FIPS packages: linux-aws-fips 6.8.0-1052.55+fips1, linux-gcp-fips 6.8.0-1054.57+fips1, and linux-fips 6.8.0-110.110+fips2. Users should update their systems to these fixed versions or later. After updating, a system reboot is required to apply the changes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be necessary. These updates are available with Ubuntu Pro. No indication of active exploitation in the wild has been reported.

Description

A vulnerability identified as EntrySign (CVE-2024-36347) affects some AMD Zen processors where CPU microcode signatures are not properly verified. This flaw allows a privileged attacker to potentially load malicious CPU microcode, leading to loss of system integrity and confidentiality. Additionally, multiple security issues in the Linux kernel affecting numerous subsystems have been addressed. These kernel vulnerabilities could allow attackers to compromise affected systems. The issues are fixed in updated Linux kernel packages for linux-aws-fips, linux-fips, and linux-gcp-fips, available with Ubuntu Pro.

References

Community reviews

Loading reviews…