Skip to main content
VulnerabilityPublished Updated

CVE-2024-27407: linux-fips, linux-aws-fips, linux-gcp-fips vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 5.15.0-1091.98+fips1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:37 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 5.15.0-1091.98+fips1, 5.15.0-153.163+fips1, 5.15.0-1091.100+fips1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 5.15.0-1091.98+fips1 (linux-aws-fips package) or 5.15.0-153.163+fips1 (linux-fips package) or 5.15.0-1091.100+fips1 (linux-gcp-fips package).

Affected software

ProductAffectedFixed in
Ubuntu Pro FIPS-updates 22.04 LTSlinux-aws-fipspkg:deb/ubuntu/linux-aws-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-1091.98+fips1
Fixed in
  • 5.15.0-1091.98+fips1
Ubuntu Pro FIPS-updates 22.04 LTSlinux-fipspkg:deb/ubuntu/linux-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-153.163+fips1
Fixed in
  • 5.15.0-153.163+fips1
Ubuntu Pro FIPS-updates 22.04 LTSlinux-gcp-fipspkg:deb/ubuntu/linux-gcp-fips?arch=source&distro=fips-updates/jammyOther threatsAffected
  • <5.15.0-1091.100+fips1
Fixed in
  • 5.15.0-1091.100+fips1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security updates provided by Ubuntu as detailed in advisory USN-7726-3. After updating, reboot the system to activate the fixes. Due to ABI changes in the updated kernels, recompile and reinstall any third-party kernel modules. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting the NTFS3 file system and network traffic control subsystems. These flaws could potentially allow an attacker to compromise affected systems. The vulnerabilities impact various linux-aws-fips kernel versions and related FIPS-certified Linux kernels. Fixes have been released and are available through Ubuntu security updates, requiring a system reboot and recompilation of third-party kernel modules due to ABI changes.

References

Community reviews

Loading reviews…