Skip to main content
VulnerabilityPublished Updated

CVE-2025-37797: linux-gcp-6.8, linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-1034.36~22.04.2 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:39 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1034.36~22.04.2, 6.8.0-1032.36

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1034.36~22.04.2 (linux-gcp-6.8 package) or 6.8.0-1032.36 (linux-raspi package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1032.36
Fixed in
  • 6.8.0-1032.36
Ubuntu 22.04 LTSlinux-gcp-6.8pkg:deb/ubuntu/linux-gcp-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1034.36~22.04.2
Fixed in
  • 6.8.0-1034.36~22.04.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately by updating to the fixed package versions: 6.8.0-1034.36~22.04.2 for Ubuntu 22.04 LTS and 6.8.0-1032.36 for Ubuntu 24.04 LTS. After updating, a system reboot is required to apply the kernel changes. Additionally, due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Standard system upgrades will handle this automatically unless kernel metapackages were manually removed.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting the network traffic control subsystem. These flaws could potentially allow an attacker to compromise affected systems. The issues impact Linux kernel versions used in Ubuntu 22.04 LTS and 24.04 LTS releases, specifically the linux-gcp-6.8 and linux-raspi kernels. Fixes have been released and are available via standard system updates, which require a reboot and recompilation of third-party kernel modules due to ABI changes.

References

Community reviews

Loading reviews…