Skip to main content
VulnerabilityPublished Updated

CVE-2025-37838: linux-gcp, linux-gcp-6.8, linux-gke vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-1043.46~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:10 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1043.46~22.04.1, 6.8.0-1043.46, 6.8.0-1039.44

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1043.46~22.04.1 (linux-gcp-6.8 package) or 6.8.0-1043.46 (linux-gcp package) or 6.8.0-1039.44 (linux-gke package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1043.46
Fixed in
  • 6.8.0-1043.46
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1039.44
Fixed in
  • 6.8.0-1039.44
Ubuntu 22.04 LTSlinux-gcp-6.8pkg:deb/ubuntu/linux-gcp-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-1043.46~22.04.1
Fixed in
  • 6.8.0-1043.46~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Users should update their systems to the fixed package versions (6.8.0-1039.44, 6.8.0-1043.46, or 6.8.0-1043.46~22.04.1 depending on their release) as detailed in the Ubuntu security notice USN-7864-1. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Several security vulnerabilities were discovered in the Linux kernel used in Google Cloud Platform (GCP) and Google Kubernetes Engine (GKE) systems, including a flaw known as VMSCAPE that allows insufficient branch predictor isolation between a guest VM and a userspace hypervisor. This could enable an attacker in a guest VM to potentially expose sensitive information from the host OS. Additional flaws affect the HSI, I2C, Bluetooth, and Timer subsystems. These issues could allow an attacker to compromise the system. Fixes have been released and require a system update and reboot.

References

Community reviews

Loading reviews…