Skip to main content
CVE-2026-31676VulnerabilityPublished Updated

linux, linux-aws, linux-azure, linux-azure-6.17, linux-hwe-6.17, linux-nvidia-6.17, linux-oem-6.17, linux-oracle

Affects Linux kernelSource GCVE Database

0
Compare
Authoritative record:CVE-2026-31676· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 6.17.0-1017.17~24.04.1 : patch Linux kernel soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.17.0-1017.17~24.04.1, 6.17.0-35.35~24.04.1, 6.17.0-1021.21 +8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-35.35
Fixed in
  • 6.17.0-35.35
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1017.17
Fixed in
  • 6.17.0-1017.17
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1017.17
Fixed in
  • 6.17.0-1017.17
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1016.16
Fixed in
  • 6.17.0-1016.16
Ubuntu 25.10linux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1018.18
Fixed in
  • 6.17.0-1018.18
Ubuntu 25.10linux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1014.16
Fixed in
  • 6.17.0-1014.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Ubuntu has released updated Linux kernel packages that fix these vulnerabilities. Users should update to the fixed versions listed in the vendor advisory and reboot their systems to apply the changes. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. The vendor advisory (https://ubuntu.com/security/notices/USN-8371-1) provides detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting various subsystems including socket buffer handling, XFRM ESP-in-TCP, RxRPC networking, ptrace, and AppArmor notifications. These flaws could allow local attackers to escalate privileges, escape containers, cause resource exhaustion, kernel crashes, memory corruption, information disclosure, or denial of service. The issues affect Ubuntu Linux kernel versions 6.8, 6.17, and 7.0, among others. Fixes have been released in updated kernel versions.

References

Community reviews

Loading reviews…