Skip to main content
CVE-2025-38561VulnerabilityPublished Updated

linux, linux-gke, linux-gkeop, linux-hwe-6.8, linux-oracle, linux-oracle-6.8, linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-94.96~22.04.1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:31 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-94.96~22.04.1, 6.8.0-1042.43~22.04.1, 6.8.0-94.96 +4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinuxpkg:deb/ubuntu/linux?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-94.96
Fixed in
  • 6.8.0-94.96
Ubuntu 24.04 LTSlinux-gkepkg:deb/ubuntu/linux-gke?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1042.47
Fixed in
  • 6.8.0-1042.47
Ubuntu 24.04 LTSlinux-gkeoppkg:deb/ubuntu/linux-gkeop?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1029.32
Fixed in
  • 6.8.0-1029.32
Ubuntu 24.04 LTSlinux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1042.43
Fixed in
  • 6.8.0-1042.43
Ubuntu 24.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1045.49
Fixed in
  • 6.8.0-1045.49
Ubuntu 22.04 LTSlinux-hwe-6.8pkg:deb/ubuntu/linux-hwe-6.8?arch=source&distro=jammyOther threatsAffected
  • <6.8.0-94.96~22.04.1
Fixed in
  • 6.8.0-94.96~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied immediately. Users must update their Linux kernel to the fixed versions listed in the Ubuntu advisory USN-8015-1 and reboot their systems to complete the update. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled after the update. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Multiple security vulnerabilities were discovered in the Linux kernel affecting subsystems including the Cryptographic API, SMB network file system, and io_uring. These flaws could allow an attacker to compromise affected systems. Fixes have been released for various Linux kernel versions, and users are advised to update and reboot to apply the patches. Due to an ABI change, recompilation of third-party kernel modules is necessary after updating.

References

Community reviews

Loading reviews…