Skip to main content
VulnerabilityPublished Updated

CVE-2026-31419: linux-lowlatency vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-31419· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 5.15.0-179.189 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Sources agree

CVSS scores by source
CNA (Linux)CVSS 3.17.8
ADP (redhat-SADP)CVSS 3.17.0
EPSS
0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.15.0-179.189
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu linux-lowlatency package to 5.15.0-179.189.

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTSlinux-lowlatencypkg:deb/ubuntu/linux-lowlatency?arch=source&distro=jammyOther threatsAffected
  • <5.15.0-179.189
Fixed in
  • 5.15.0-179.189

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security update provided by Ubuntu (linux-lowlatency kernel version 5.15.0-179.189 or later) as detailed in USN-8351-1. After updating, reboot the system to activate the fixes. Due to an ABI change in the kernel update, recompile and reinstall any third-party kernel modules installed on the system. Following these steps will mitigate the vulnerabilities.

Description

Multiple security vulnerabilities were discovered in the Linux kernel low latency variant, affecting subsystems including the Cryptographic API, Ethernet bonding driver, Packet sockets, and TLS protocol. One notable flaw, known as Copy Fail (CVE-2026-31431), involves improper handling of in-place cryptographic operations in the algif_aead module. These vulnerabilities could allow a local attacker to escalate privileges or potentially escape container environments. A security update addressing these issues has been released and requires a system reboot and recompilation of third-party kernel modules due to ABI changes.

References

Community reviews

Loading reviews…