CVE-2026-31419: linux-nvidia-tegra vulnerabilities
Affects Linux kernelSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.8 High : upgrade to 6.8.0-1025.25 soon.
Data as of 5 Nov 2026, 00:01 UTC
Sources agree
| CNA (Linux) | CVSS 3.1 | 7.8 |
|---|---|---|
| ADP (redhat-SADP) | CVSS 3.1 | 7.0 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8.0-1025.25
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the Ubuntu linux-nvidia-tegra package to 6.8.0-1025.25.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-nvidia-tegrapkg:deb/ubuntu/linux-nvidia-tegra?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by updating the linux-nvidia-tegra kernel to version 6.8.0-1025.25 or later. After updating, a system reboot is required to apply the changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Follow the Ubuntu security advisory USN-8350-1 for detailed update instructions.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for NVIDIA Tegra systems, including a flaw in the algif_aead cryptographic module that improperly handles in-place cryptographic operations (Copy Fail). These issues affect several subsystems such as the Cryptographic API, Ethernet bonding driver, Packet sockets, and TLS protocol. A local attacker could exploit these vulnerabilities to escalate privileges or potentially escape container isolation. The vulnerabilities have been addressed in kernel version 6.8.0-1025.25.
References
- ubuntu.com/security/notices/USN-8350-1 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31419 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31431 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31504 (opens in a new tab)
- ubuntu.com/security/CVE-2026-31533 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43033 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43077 (opens in a new tab)
- ubuntu.com/security/CVE-2026-43078 (opens in a new tab)
- ubuntu.com/security/CVE-2026-46028 (opens in a new tab)