CVE-2025-38477: linux-oracle, linux-oracle-6.14 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.14.0-1014.14~24.04.1 soon.
Data as of 3 Nov 2026, 17:44 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.14.0-1014.14~24.04.1
Exploitation evidence
Disclosed: evidence found.
CVE published 14 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade the Ubuntu linux-oracle-6.14 package to 6.14.0-1014.14~24.04.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-oracle-6.14pkg:deb/ubuntu/linux-oracle-6.14?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied immediately. Users must upgrade to linux-oracle-6.14 version 6.14.0-1014.14~24.04.1 or later. After updating, a system reboot is required to apply the changes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.
Description
Multiple security vulnerabilities were discovered in the Linux kernel used in the linux-oracle-6.14 package. These flaws affect subsystems including packet sockets, network traffic control, VMware vSockets driver, and the XFRM subsystem. An attacker could potentially exploit these vulnerabilities to compromise the system. A security update has been released to address these issues, requiring a system reboot and recompilation of third-party kernel modules due to an ABI change.