Skip to main content
VulnerabilityPublished Updated

CVE-2025-37838: linux-raspi, linux-raspi-realtime, linux-xilinx vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.0-1042.46 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:10 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1042.46, 6.8.0-1019.20, 6.8.0-2033.34

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.0-1042.46 (linux-raspi package) or 6.8.0-1019.20 (linux-xilinx package) or 6.8.0-2033.34 (linux-raspi-realtime package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1042.46
Fixed in
  • 6.8.0-1042.46
Ubuntu 24.04 LTSlinux-xilinxpkg:deb/ubuntu/linux-xilinx?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1019.20
Fixed in
  • 6.8.0-1019.20
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.0-2033.34
Fixed in
  • 6.8.0-2033.34

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating to the fixed kernel versions 6.8.0-1042.46, 6.8.0-1019.20, or 6.8.0-2033.34 as appropriate for the platform. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Users should follow the official Ubuntu security notice USN-7861-5 for detailed update instructions.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi, Raspberry Pi Real-time, and Xilinx systems. These include a branch predictor isolation flaw known as VMSCAPE (CVE-2025-40300) that could allow an attacker in a guest VM to expose sensitive information from the host OS. Additional flaws affect the HSI, Bluetooth, and Timer subsystems. Updates correcting these issues have been released and require a system reboot and recompilation of third-party kernel modules due to ABI changes.

References

Community reviews

Loading reviews…