CVE-2024-58090: linux-raspi vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited : upgrade to 6.8.0-1039.43 soon.
Data as of 31 Oct 2026, 01:36 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.0-1039.43
Exploitation evidence
Disclosed: evidence found.
CVE published 1 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu linux-raspi package to 6.8.0-1039.43.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing these vulnerabilities is available and should be applied promptly. Users should update to linux-image-6.8.0-1039-raspi version 6.8.0-1039.43 or later and reboot the system to apply the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled after the update. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.
Description
Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi systems affecting numerous subsystems including architectures, drivers, networking, and core kernel components. These flaws could potentially allow an attacker to compromise the system. A security update addressing these issues has been released and requires a system reboot and recompilation of third-party kernel modules due to ABI changes.
References
- ubuntu.com/security/notices/USN-7790-1 (opens in a new tab)
- ubuntu.com/security/CVE-2024-58090 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21872 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21873 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21875 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21877 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21878 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21880 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21881 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21883 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21885 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21888 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21889 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21890 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21891 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21892 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21894 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21895 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21898 (opens in a new tab)
- ubuntu.com/security/CVE-2025-21899 (opens in a new tab)